Project

General

Profile

機能 #462

Android 6.0 以下をサポート

Added by みぞ @mizo0203 almost 3 years ago. Updated almost 3 years ago.

Status:
完了
Priority:
通常
Target version:
Start date:
11/27/2018
Due date:
% Done:

100%

Estimated time:
Spent time:

Description

minSdkVersion を Android 5.1 (API level 22) に設定する

  • Android 5.1 未満だと GridLayout が崩れる
  • Android 5.1 以降をサポートすることで 80.2 % の Android デバイスでアプリを起動できる
  • 将来的に Travis CI で Android emulator を用いた自動テストを行うならば API level 22 のサポートが必要
#1

Updated by みぞ @mizo0203 almost 3 years ago

  • Target version set to v0.2.1
#2

Updated by みぞ @mizo0203 almost 3 years ago

  • Description updated (diff)
  • Status changed from 新規 to 進行中
  • % Done changed from 0 to 40
#3

Updated by みぞ @mizo0203 almost 3 years ago

  • Status changed from 進行中 to 解決
  • % Done changed from 40 to 80

更新履歴 github|14d531bb158e211678d32f69d2d014ddde1b4897 で適用されました。

#4

Updated by みぞ @mizo0203 almost 3 years ago

  • Status changed from 解決 to 完了
  • % Done changed from 80 to 100
#5

Updated by みぞ @mizo0203 almost 3 years ago

minSdkVersion を Android 5.1 (API level 22) に設定するとビルドエラーが発生したた
Java 8 サポートによって解決できる

Error: Default interface methods are only supported starting with Android N (--min-api 24): boolean com.google.common.base.Predicate.test(java.lang.Object)

Also available in: Atom PDF